<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>South Portland girls roll at Windham to stay undefeated - Keep Me Current</title>
    <meta charset="UTF-8"/>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://news.keepmecurrent.com/xmlrpc.php"/>
    <meta property="og:image" content="http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg"/><meta name="author" content="Michael Hoffer">

<!-- This site is optimized with the Yoast SEO plugin v6.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="South Portland girls roll at Windham to stay undefeated - Keep Me Current"/>
<meta property="og:description" content="South Portland senior Meghan Graff chases Windham junior Meghan Hoffses during the Red Riots&#8217; 50-28 victory Monday evening. South Portland improved to 8-0 with the win. Joe Carpine / 365digitalphotography.com photos. More photos below. WINDHAM—Entering its most challenging stretch of the season so far, South Portland&#8217;s highly touted girls&#8217; basketball team made quick work of"/>
<meta property="og:url" content="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/"/>
<meta property="og:site_name" content="Keep Me Current"/>
<meta property="article:tag" content="rss"/>
<meta property="article:section" content="Sports"/>
<meta property="article:published_time" content="2018-01-08T23:15:00-05:00"/>
<meta property="article:modified_time" content="2018-01-08T23:20:32-05:00"/>
<meta property="og:updated_time" content="2018-01-08T23:20:32-05:00"/>
<meta property="og:image" content="http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg"/>
<meta property="og:image:width" content="867"/>
<meta property="og:image:height" content="768"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="South Portland senior Meghan Graff chases Windham junior Meghan Hoffses during the Red Riots&#8217; 50-28 victory Monday evening. South Portland improved to 8-0 with the win. Joe Carpine / 365digitalphotography.com photos. More photos below. WINDHAM—Entering its most challenging stretch of the season so far, South Portland&#8217;s highly touted girls&#8217; basketball team made quick work of "/>
<meta name="twitter:title" content="South Portland girls roll at Windham to stay undefeated - Keep Me Current"/>
<meta name="twitter:image" content="http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg"/>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/news.keepmecurrent.com\/","name":"Keep Me Current","potentialAction":{"@type":"SearchAction","target":"http:\/\/news.keepmecurrent.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maps.googleapis.com'/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; Feed" href="http://news.keepmecurrent.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; Comments Feed" href="http://news.keepmecurrent.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; South Portland girls roll at Windham to stay undefeated Comments Feed" href="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/feed/"/>
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/news.keepmecurrent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
<link rel='stylesheet' id='dashicons-css' href='http://news.keepmecurrent.com/wp-includes/css/A.dashicons.min.css,qver=4.9.1.pagespeed.cf.LT4V6Htg4t.css' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='http://news.keepmecurrent.com/wp-includes/css/A.jquery-ui-dialog.min.css,qver=4.9.1.pagespeed.cf.nsTq5IW5Gz.css' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-four-css' href='http://news.keepmecurrent.com/wp-content/plugins/font-awesome-4-menus/css/A.font-awesome.min.css,qver=4.7.0.pagespeed.cf.jBrWCt-D4j.css' type='text/css' media='all'/>
<link rel='stylesheet' id='orgseries-default-css-css' href='http://news.keepmecurrent.com/wp-content/plugins/organize-series/A.orgSeries.css,qver=4.9.1.pagespeed.cf.f8oSIa3t_Y.css' type='text/css' media='all'/>
<link rel='stylesheet' id='rs-plugin-settings-css' href='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/css/A.settings.css,qver=5.1.6.pagespeed.cf.5rzHaygmgO.css' type='text/css' media='all'/>
<style id='rs-plugin-settings-inline-css' type='text/css'>#rs-demo-id{}</style>
<link rel='stylesheet' id='google_font_open_sans-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.9.1' type='text/css' media='all'/>
<link rel='stylesheet' id='google_font_roboto-css' href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;ver=4.9.1' type='text/css' media='all'/>
<link rel='stylesheet' id='better-weather-css' href='http://news.keepmecurrent.com/wp-content/plugins/better-weather/includes/libs/better-weather/css/A.bw-style.min.css,qver=2.0.3.pagespeed.cf.iBYAO5dXFt.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/pro/assets/css/A.ubermenu.min.css,qver=3.2.1.1.pagespeed.cf.U0oqAwkzDS.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-black-white-2-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/css/skins/A.blackwhite2.css,qver=4.9.1.pagespeed.cf.3ORV6MNaSL.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-font-awesome-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/css/fontawesome/css/A.font-awesome.min.css,qver=4.3.pagespeed.cf.iIGKnvKx_M.css' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='http://news.keepmecurrent.com/wp-content/themes/Newspaper/A.style.css,qver=6.1c.pagespeed.cf.3DiuhbUCi6.css' type='text/css' media='all'/>
<style id='td-theme-child-css' media='all'>.wp-caption-text{text-align:right;padding:2px 1px}</style>
<link rel='stylesheet' id='js_composer_front-css' href='http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/A.js_composer.min.css,qver=4.11.2.pagespeed.cf.T30Vpn3vIW.css' type='text/css' media='all'/>
<link rel='stylesheet' id='dhvc-waypoint-css' href='http://news.keepmecurrent.com/wp-content/plugins/dhvc-waypoint/assets/css/A.style.css,qver=4.9.1.pagespeed.cf.QiSdOMchuc.css' type='text/css' media='all'/>
<link rel='stylesheet' id='dhvc-waypoint-v2-css' href='http://news.keepmecurrent.com/wp-content/plugins/dhvc-waypoint/assets/css/A.stylev2.min.css,qver=4.9.1.pagespeed.cf.cqDgGaF-uB.css' type='text/css' media='all'/>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-includes/js/jquery/jquery.js,qver=1.12.4.pagespeed.jm.pPCPAKkkss.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-includes/js/jquery/jquery-migrate.min.js,qver=1.4.1.pagespeed.jm.C2obERNcWh.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js,qver=5.1.6.pagespeed.jm.hKSbRSQ3n8.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js,qver=5.1.6.pagespeed.jm.ZqIGaMtVT-.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/themes/Newspaper-child/dfp-gpt1.js?ver=4.9.1'></script>
<link rel='https://api.w.org/' href='http://news.keepmecurrent.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://news.keepmecurrent.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://news.keepmecurrent.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 4.9.1"/>
<link rel='shortlink' href='http://news.keepmecurrent.com/?p=268953'/>
<link rel="alternate" type="application/json+oembed" href="http://news.keepmecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://news.keepmecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F&#038;format=xml"/>
<!--[if IE 9]> <script>var _gambitParallaxIE9 = true;</script> <![endif]--><style id="ubermenu-custom-generated-css"></style><script type="text/javascript">(function(url){if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){return;}var addEvent=function(evt,handler){if(window.addEventListener){document.addEventListener(evt,handler,false);}else if(window.attachEvent){document.attachEvent('on'+evt,handler);}};var removeEvent=function(evt,handler){if(window.removeEventListener){document.removeEventListener(evt,handler,false);}else if(window.detachEvent){document.detachEvent('on'+evt,handler);}};var evts='contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');var logHuman=function(){var wfscr=document.createElement('script');wfscr.type='text/javascript';wfscr.async=true;wfscr.src=url+'&r='+Math.random();(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);for(var i=0;i<evts.length;i++){removeEvent(evts[i],logHuman);}};for(var i=0;i<evts.length;i++){addEvent(evts[i],logHuman);}})('//news.keepmecurrent.com/?wordfence_lh=1&hid=475BA13B07762CDE31E3EF304E376A6E');</script><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.1.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface."/>

<!-- JS generated by theme -->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .post img";var td_ajax_url="http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.7.2";var td_get_template_directory_uri="http:\/\/news.keepmecurrent.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="9";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="3";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#4db2ec";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var td_ad_background_click_link="";var td_ad_background_click_target="";</script>


<!-- Header style compiled by theme -->

<style>.block-title>span,.block-title>a,.block-title>label,.widgettitle,.widgettitle:after,.td-trending-now-title,.td-trending-now-wrapper:hover .td-trending-now-title,.wpb_tabs li.ui-tabs-active a,.wpb_tabs li:hover a,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab.vc_active>a,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab:hover>a,.td-related-title .td-cur-simple-item,.woocommerce .product .products h2,.td-subcat-filter .td-subcat-dropdown:hover .td-subcat-more,.td-weather-information:before,.td-weather-week:before{background-color:#222}.woocommerce div.product .woocommerce-tabs ul.tabs li.active{background-color:#222!important}.block-title,.td-related-title,.wpb_tabs .wpb_tabs_nav,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container,.woocommerce div.product .woocommerce-tabs ul.tabs:before{border-color:#222}.td-footer-wrapper{background-color:#999}.td-footer-wrapper::before{background-repeat:repeat}.td-footer-wrapper::before{opacity:.3}</style>

<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-328783-34','auto');ga('send','pageview');</script><noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head>

<body class="post-template-default single single-post postid-268953 single-format-standard south-portland-girls-roll-at-windham-to-stay-undefeated wpb-js-composer js-comp-ver-4.11.2 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div id="td-mobile-nav">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-category-container"><ul id="menu-category" class=""><li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-39"><a href="http://news.keepmecurrent.com/category/news/">News</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35"><a href="http://news.keepmecurrent.com/category/community/">Community</a>
<ul class="sub-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="http://news.keepmecurrent.com/category/calendar/">Calendar</a></li>
</ul>
</li>
<li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="http://news.keepmecurrent.com/category/lifestyle/">Lifestyle</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41"><a href="http://news.keepmecurrent.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"><a href="http://news.keepmecurrent.com/category/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-42" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42"><a href="http://news.keepmecurrent.com/category/police-beat/">Police Beat</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-43"><a href="http://news.keepmecurrent.com/category/sports/">Sports</a></li>
<li id="menu-item-249203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-249203"><a href="http://news.keepmecurrent.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-249204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-249204"><a href="http://news.keepmecurrent.com/about-us/">About Us</a></li>
	<li id="menu-item-249466" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-249466"><a href="http://news.keepmecurrent.com/advertise/">Advertise</a>
	<ul class="sub-menu">
		<li id="menu-item-255734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255734"><a href="http://local.keepmecurrent.com/">Local Business Directory</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-250775" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250775"><a href="http://classifieds.keepmecurrent.com">Classifieds</a></li>
</ul></div>    </div>
</div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 9
-->

<div class="td-header-wrap td-header-style-9">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="td_data_time">Tuesday, January 9, 2018</div><div class="menu-top-container"><ul id="menu-edition" class="top-header-menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-12"><a href="http://news.keepmecurrent.com/category/american-journal/">American Journal</a>
<ul class="sub-menu">
	<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13"><a href="http://news.keepmecurrent.com/category/american-journal/buxton/">Buxton</a></li>
	<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14"><a href="http://news.keepmecurrent.com/category/american-journal/gotham/">Gorham</a></li>
	<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15"><a href="http://news.keepmecurrent.com/category/american-journal/westbrook/">Westbrook</a></li>
</ul>
</li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-16"><a href="http://news.keepmecurrent.com/category/current/">Current</a>
<ul class="sub-menu">
	<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-17"><a href="http://news.keepmecurrent.com/category/current/capeelizabeth/">Cape Elizabeth</a></li>
	<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-18"><a href="http://news.keepmecurrent.com/category/current/scarborough/">Scarborough</a></li>
	<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-19"><a href="http://news.keepmecurrent.com/category/current/southportland/">South Portland</a></li>
</ul>
</li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-20"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/">Lakes Region Weekly</a>
<ul class="sub-menu">
	<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/bridgton/">Bridgton</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-22"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/casco/">Casco</a></li>
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-23"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/gray/">Gray</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-24"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/naples/">Naples</a></li>
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-25"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/new-gloucdster/">New Gloucester</a></li>
	<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-26"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/raymond/">Raymond</a></li>
	<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-27"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/sebago/">Sebago</a></li>
	<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-28"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/standish/">Standish</a></li>
	<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/windham/">Windham</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-30"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/">Tri-Town Weekly</a>
<ul class="sub-menu">
	<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-31"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/durham/">Durham</a></li>
	<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-32"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/freeport/">Freeport</a></li>
	<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-33"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/pownal/">Pownal</a></li>
</ul>
</li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    <span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/keepmecurrent/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/currentreports" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></div>
    </div>

        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-header-sp-logo">
                <span class="logo-text-container">
		<a class="td-logo-wrap" href="http://news.keepmecurrent.com/">
			<span class="td-logo-text">Keep Me Current</span>
			<span class="td-tagline-text">News from where you live</span>
		</a>
    </span>
	        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
            </div>
    <div class="menu-category-container"><ul id="menu-category-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-39"><a href="http://news.keepmecurrent.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-35"><a href="http://news.keepmecurrent.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-34"><a href="http://news.keepmecurrent.com/category/calendar/">Calendar</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38"><a href="http://news.keepmecurrent.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-41"><a href="http://news.keepmecurrent.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-37"><a href="http://news.keepmecurrent.com/category/letters/">Letters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42"><a href="http://news.keepmecurrent.com/category/police-beat/">Police Beat</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-43"><a href="http://news.keepmecurrent.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-249203"><a href="http://news.keepmecurrent.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-249204"><a href="http://news.keepmecurrent.com/about-us/">About Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-249466"><a href="http://news.keepmecurrent.com/advertise/">Advertise</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-255734"><a href="http://local.keepmecurrent.com/">Local Business Directory</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-250775"><a href="http://classifieds.keepmecurrent.com">Classifieds</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form role="search" method="get" class="td-search-form" action="http://news.keepmecurrent.com/">
				<div class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search"/>
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header "><script type='text/javascript'>var gptAdSlots=[];googletag.cmd.push(function(){var bigLeaderMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([320,400],[320,50]).addSize([750,200],[728,90]).addSize([1024,768],[970,250]).build();var leaderMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([320,400],[320,50]).addSize([750,200],[728,90]).build();var sidebarMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([750,250],[300,600]).build();gptAdSlots[0]=googletag.defineSlot('/23938892/CUR_ROP_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032504433-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[1]=googletag.defineSlot('/23938892/CUR_STORY_1_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032915837-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[2]=googletag.defineSlot('/23938892/CUR_STORY_2_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032989449-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[3]=googletag.defineSlot('/23938892/CUR_FRONT_1_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032611748-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[4]=googletag.defineSlot('/23938892/CUR_FRONT_2_728X90',[[728,90],[320,90]],'div-gpt-ad-1460032682508-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[5]=googletag.defineSlot('/23938892/CUR_FRONT_3_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032790952-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[6]=googletag.defineSlot('/23938892/CUR_FRONT_2_300X250',[300,250],'div-gpt-ad-1460034409432-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[7]=googletag.defineSlot('/23938892/CUR_FRONT_1_300X600',[300,600],'div-gpt-ad-1460035808376-0').defineSizeMapping(sidebarMap).addService(googletag.pubads());googletag.pubads().setTargeting("test","responsive");googletag.enableServices();});</script>

<!-- /23938892/CUR_ROP_728X90 -->
<div id='div-gpt-ad-1460032504433-0' style='width: 728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032504433-0');});</script>
</div>
</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://news.keepmecurrent.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Sports" class="entry-crumb" itemprop="url" href="http://news.keepmecurrent.com/category/sports/"><span itemprop="title">Sports</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content="South Portland girls roll at Windham to stay undefeated"><meta itemprop="url" content="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/">South Portland girls roll at Windham to stay undefeated</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-268953" class="post-268953 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-rss" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">South Portland girls roll at Windham to stay undefeated</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://news.keepmecurrent.com/author/current-publishing/">Michael Hoffer</a> - </div>                    <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-01-08T23:15:00+00:00">January 8, 2018</time></div>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-268953">5</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=South+Portland+girls+roll+at+Windham+to+stay+undefeated&url=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F&via=currentreports"><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/&amp;media=http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg&description=South+Portland+girls+roll+at+Windham+to+stay+undefeated" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=South+Portland+girls+roll+at+Windham+to+stay+undefeated - http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F"><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><a href="http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg" data-caption="South Portland senior Meghan Graff chases Windham junior Meghan Hoffses during the Red Riots&#039; 50-28 victory Monday evening. South Portland improved to 8-0 with the win. Joe Carpine / 365digitalphotography.com photos. More photos below."><img width="696" height="617" class="entry-thumb td-modal-image" src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_0944-696x617.jpg.pagespeed.ic.KWMI1O2gmZ.jpg" alt="" title=""/></a><figcaption class="wp-caption-text">South Portland senior Meghan Graff chases Windham junior Meghan Hoffses during the Red Riots' 50-28 victory Monday evening. South Portland improved to 8-0 with the win. Joe Carpine / 365digitalphotography.com photos. More photos below.</figcaption></figure></div>
        <div class="td-a-rec td-a-rec-id-content_top ">​<!-- /23938892/CUR_STORY_1_728X90 -->
<div id='div-gpt-ad-1460032915837-0' style='maxwidth:728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032915837-0');});</script>
</div></div><p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_0944.jpg.pagespeed.ic.JxCFG5_epJ.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland senior Meghan Graff chases Windham junior Meghan Hoffses during the Red Riots&#8217; 50-28 victory Monday evening. South Portland improved to 8-0 with the win.</p>
<p>Joe Carpine / 365digitalphotography.com photos.</p>
<p>More photos below.</p>
<p>WINDHAM—Entering its most challenging stretch of the season so far, South Portland&#8217;s highly touted girls&#8217; basketball team made quick work of the dangerous Windham Eagles Monday evening.</p>
<p>Other than surrendering a layup off the opening tip, the visiting Red Riots controlled the first quarter, forcing eight turnovers and racing to a 13-5 lead behind six points and three steals from senior standout Meghan Graff.</p>
<p>The second period was more of the same as South Portland stretched its advantage to 17 before Windham junior Meghan Hoffses hit a late 3-pointer to make the score 26-12 at halftime.</p>
<p>The Red Riots then ended any doubt early in the third quarter, as sophomore Maggie Whitmore, junior Katie Whitmore and Graff all converted layups and South Portland went ahead by 25, 42-17.</p>
<p>In the fourth period, the Red Riots&#8217; reserves were just as impressive as the starters and they put the finishing touches on an impressive and emphatic 50-28 victory.</p>
<p>Graff led a balanced attack with 18 points and 10 different players scored as South Portland improved to 8-0 and in the process, dropped Windham to 3-5.</p>
<p>&#8220;Our main goal is always to come out and get a good lead,&#8221; Graff said. &#8220;When we do that, we get into the game intensity-wise. We knew it would be a tough game coming up here. A lot of teams want to beat us this year and every game, we have to be ready to play.&#8221; </p>
<h3>Grounding the Eagles</h3>
<p>South Portland entered the 2017-18 season as the favorite in Class AA and the Red Riots haven&#8217;t disappointed. They opened with wins over visiting Bonny Eagle (61-41), Cheverus (49-31) and Greely (<a href="http://www.theforecaster.net/dewolfe-reaches-1000-but-greely-drops-interclass-showdown-at-sp/" target="_blank">63-53</a>), host Scarborough (<a href="http://www.theforecaster.net/south-portland-girls-surge-late-to-win-at-scarborough/" target="_blank">40-32</a>) and visiting Oxford Hills (49-32). South Portland then opened the new year by dispatching visiting Sanford (62-26) and winning at Massabesic (49-26). </p>
<p>Windham, meanwhile, has been up-and-down, but has been very competitive in the process. After starting with a 46-43 home win over Cheverus, the Eagles lost at Portland (49-40) and at home to Bangor (50-46). After downing host Noble (56-41) and visiting Massabesic (44-26), Windham dropped a 47-43 decision at Edward Little and Friday, fell at home to Maine Girls&#8217; Academy (68-62).</p>
<p>Last year, South Portland won at Windham, 49-31.</p>
<p>Monday, the Eagles sought their first victory over the Red Riots since a 55-47 triumph Dec. 9, 2011 in South Portland, but instead, the Red Riots made it six straight in the series with relative ease.</p>
<p>Windham&#8217;s highlight came on the opening tip, as junior Tara Flanders set up Hoffses for a layup four seconds in.</p>
<p>The majority of the next 1,916 seconds then belonged to South Portland.</p>
<p>The visitors raced right down and tied the score when Graff set up senior Sarah Boles for a layup and with 6:26 to play in the first quarter, Graff&#8217;s first points, a pair of free throws, put the Red Riots ahead to stay.</p>
<p>After Graff spun and made a layup, Eagles coach Brody Artes called timeout, but it didn&#8217;t help, as Graff scored again, on a long jumper, for an 8-2 lead.</p>
<p>With 2:54 remaining in the frame, Windham snapped the 8-0 run and a 5-minute, 2-second drought when Hoffses sank a 3 from the corner, but Maggie Whitmore answered with a putback while being fouled and added the free throw for the old-fashioned three-point play. Then, with 2.5 seconds on the clock, Katie Whitmore set up junior Jena Leckie for a layup and a 13-5 advantage.</p>
<p>In the first eight minutes, the Eagles&#8217; eight turnovers helped South Portland open up the lead.</p>
<p>&#8220;I thought that we ran really well in transition,&#8221; Red Riots coach Lynne Hasson said. &#8220;We made nice passes and got up and down the court. We scored a lot of points off turnovers. That set the tone early. That&#8217;s who we are. When we run, we&#8217;re pretty good.&#8221;  </p>
<p>Senior Taylor Files started the second quarter with a free throw for the hosts, but Maggie Whitmore countered with a pair for the Red Riots. After Windham sophomore Emily Drummond kept play alive with an offensive rebound, Hoffses made a 3, but the next 11 points went to the visitors.</p>
<p>South Portland&#8217;s run started when senior Eva Mazur set up Graff for a fastbreak layup. Mazur added a 3, Graff hit a long jumper, Graff got a leaner to bounce around and in and with 47.2 seconds on the clock, Graff banked home a shot for a 17-point lead.</p>
<p>Hoffses sank a 3-ball with 13.1 seconds to go, but that only brought the Eagles within 26-12 at halftime.</p>
<p>In the first half, Graff had 14 points to lead the Red Riots, while Hoffses had 11 for Windham, but South Portland had eight more possessions due to 15 Eagles&#8217; turnovers to their seven.</p>
<p>&#8220;Defense is always our main focus,&#8221; said Graff. &#8220;Eva is one of the top defenders around and Maggie is a big help in the post. Defense makes a big impact on the game.&#8221; </p>
<p>Early in the third quarter, Mazur fed Maggie Whitmore for a layup, Whitmore fed her sister, Katie Whitmore, for a layup and Bowles set up Graff for a layup and a 32-12 lead.</p>
<p>Windham stemmed the tide with a long jumper from junior Tara Flanders, but Graff made a bank shot. After a Flanders free throw, Bowles sank a 3. Hoffses banked home a runner, but sophomore Ashlee Aceto made a jumper for South Portland, Leckie sank a free throw and as time expired, Aceto made another jumper for a 42-17 advantage.</p>
<p>The fourth period saw a large dose of Red Riots reserves who comported themselves quite nicely.</p>
<p>After Hoffses scored on a leaner in the lane, sophomore Olivia Cloutier sank a long jumper for the visitors and sophomore Kaleisha Towle added a pair of foul shots to make it 46-19. Junior Kayla Gorman answered with a 3 for Windham and Files added a jumper, but Cloutier set up freshman Cora Boothby-Akilo for a layup. Sophomore Hannah Talon drove for a layup and Flanders set up Hoffses for a fastbreak layup for the Eagles&#8217; final points before a layup after a steal by Towle in the final minute brought the curtain down on South Portland&#8217;s 50-28 victory.</p>
<p>Graff led all scorers with 18 points and also had four steals and three assists.</p>
<p>Maggie Whitmore was her usual prolific self, scoring seven points and grabbing 11 rebounds.</p>
<p>Bowles had five points, Aceto (five rebounds, two steals) and Towle added four apiece, Leckie (five boards) and Mazur had three each and Boothby-Akilo, Cloutier and Katie Whitmore finished with two apiece. Junior Bela Cloutier and freshman Maria Degifico also saw time off the bench.</p>
<p>&#8220;All of our players are awesome,&#8221; said Graff. &#8220;It&#8217;s the same level of talent. (The reserves) push the starters to work harder and get better.&#8221;</p>
<p>&#8220;My goal is to get all the girls out there and get them comfortable,&#8221; Hasson said. &#8220;We have a big week coming up, so if the starters can get some rest, great. I trust the younger kids. Kaleisha is a good help defender and gets rebounds. Ashlee is steady and was great off the bench. Both Cloutiers play good defense. The freshmen are young, but everyone else has been around. We have a strong bench.&#8221;</p>
<p>The Red Riots won the rebound battle, 37-34, overcame 16 turnovers and shot 8 of 10 from the free throw line.</p>
<p>&#8220;We&#8217;ve made vast improvement in taking care of the ball,&#8221; Hasson said. &#8220;Limiting turnovers has been a key to us getting better.&#8221; </p>
<p>Windham got more than half its points from Hoffses, who had 17. Files, Flanders (six rebounds, four assists) and Gorman had three points apiece and Tolan finished with two (to go with seven rebounds). Drummond didn&#8217;t score, but had five rebounds and blocked two shots.</p>
<p>The Eagles turned the ball over 23 times and made 2 of 4 free throws.</p>
<p>&#8220;A lot of credit to South Portland and the pressure they put on us,&#8221; said Artes. &#8220;We didn&#8217;t handle it well or take care of the ball well enough. We didn&#8217;t get in the paint like we usually do and we missed a lot of shots too. A combination of those two things wasn&#8217;t good for us.</p>
<p>&#8220;Meghan had a good game and shot the ball well. She&#8217;s a competitor for sure. They did a really good job on Hannah. Tara had a couple fouls early. It was tough to get in an offensive flow. We rely on those three to drive together out there for us to have success.</p>
<p>&#8220;South Portland has grown since last year. They&#8217;re a little longer than they were. More so than anyone else in the league, they have more depth. When they go to the bench, they bring in either a really good athlete, a really good basketball player or both. That&#8217;s the difference between them and other teams.&#8221; </p>
<h3>Busy stretch</h3>
<p>Windham looks to bounce back Thursday at Sanford. The Eagles then stay on the road Saturday at Scarborough and Monday at Bangor. </p>
<p>&#8220;This was a good test for where we&#8217;re at and we&#8217;re not quite where we want to be,&#8221; Artes said. &#8220;We&#8217;ve been in every game. We&#8217;re still trying to figure some things out. I like our mix. We just have to put it together and click at the right time. Anything can happen.&#8221;</p>
<p>South Portland, meanwhile, will only find that the road gets tougher. The Red Riots travel to dangerous Portland Thursday, then visit Maine Girls&#8217; Academy Saturday. The weekend of Jan. 19-20, South Portland hosts Deering and Thornton Academy. Of course, a highly anticipated showdown at Gorham also looms on Feb. 2 in Gorham.</p>
<p>&#8220;It&#8217;s exciting, but we&#8217;re taking it one game at a time and we won&#8217;t look past anyone,&#8221; Graff said. &#8220;Thursday will be a good test for us. I&#8217;m happy, but I don&#8217;t think we&#8217;ve played at our full potential yet. I want us to play our best come tournament time. We&#8217;re having fun.&#8221;</p>
<p>&#8220;Portland is the most athletic team I&#8217;ve seen in awhile,&#8221; Hasson said. &#8220;We run and they run and if we take care of the ball, it will be a fun game. MGA is tough. Player for player, they have talent. They always play good defense. That&#8217;s a tough gym. It&#8217;s always a horrible place for us. </p>
<p>&#8220;The kids are having fun. They&#8217;re very unselfish. Sometimes to a fault. Once we figure out how to finish in the paint, we&#8217;ll be scary.&#8221;</p>
<h4 style="text-align: center">Sports Editor Michael Hoffer can be reached at <a href="mailto:mhoffer@theforecaster.net" rel="noopener" target="_blank">mhoffer@theforecaster.net</a>. Follow him on Twitter: <a title="@foresports" href="http://twitter.com/#%21/foresports" rel="noopener" target="_blank">@foresports</a>.</h4>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_1010.jpg.pagespeed.ic.LKLnLFyiUW.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland junior Katie Whitmore goes up for a shot as Windham junior Tara Flanders defends.</p>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_1253.jpg.pagespeed.ic.QtNrtiOvui.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland sophomore Kaleisha Towle shoots over Windham junior Kayla Gorman.</p>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_0905.jpg.pagespeed.ic.BL6nyfGuTo.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland senior Eva Mazur (4) and sophomore Maggie Whitmore battle Windham junior Mikayla Baiguy for the ball.</p>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_0928_4.jpg.pagespeed.ic.6T4lpfE1ht.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland junior Jena Leckie guards Windham junior Alanna Joyce.</p>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/xIMG_0993.jpg.pagespeed.ic.0t1brcY0EY.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<p>South Portland sophomore Maggie Whitmore makes a layup as Windham junior Tara Flanders defends.</p>
<div class="td-a-rec td-a-rec-id-content_bottom ">​<!-- /23938892/CUR_STORY_2_728X90 -->
<div id='div-gpt-ad-1460032989449-0' style='maxwidth:728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032989449-0');});</script>
</div>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=South+Portland+girls+roll+at+Windham+to+stay+undefeated&url=http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F&via=currentreports"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/&amp;media=http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg&description=South+Portland+girls+roll+at+Windham+to+stay+undefeated" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=South+Portland+girls+roll+at+Windham+to+stay+undefeated - http%3A%2F%2Fnews.keepmecurrent.com%2Fsouth-portland-girls-roll-at-windham-to-stay-undefeated%2F"><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/" data-text="South Portland girls roll at Windham to stay undefeated" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>                        <div class="author-box-wrap"><a href="http://news.keepmecurrent.com/author/current-publishing/"><img src="http://2.gravatar.com/avatar/e064b2421f78c4290b2977e5b26aa199?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://news.keepmecurrent.com/author/current-publishing/">Michael Hoffer</a></span></div><div class="td-author-url"><a href="http://www.keepmecurrent.com">http://www.keepmecurrent.com</a></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Michael Hoffer"></span><meta itemprop="datePublished" content="2018-01-08T23:15:00+00:00"><meta itemprop="dateModified" content="2018-01-08T23:20:32+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="Keep Me Current"></span><meta itemprop="headline " content="South Portland girls roll at Windham to stay undefeated"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://news.keepmecurrent.com/wp-content/uploads/2018/01/IMG_0944.jpg"><meta itemprop="width" content="867"><meta itemprop="height" content="768"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_1_5a54ab5ef05f1=new tdBlock();block_td_uid_1_5a54ab5ef05f1.id="td_uid_1_5a54ab5ef05f1";block_td_uid_1_5a54ab5ef05f1.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_1_5a54ab5ef05f1_rand","td_column_number":3,"live_filter_cur_post_id":268953,"live_filter_cur_post_author":"9"}';block_td_uid_1_5a54ab5ef05f1.td_column_number="3";block_td_uid_1_5a54ab5ef05f1.block_type="td_block_related_posts";block_td_uid_1_5a54ab5ef05f1.post_count="3";block_td_uid_1_5a54ab5ef05f1.found_posts="4595";block_td_uid_1_5a54ab5ef05f1.header_color="";block_td_uid_1_5a54ab5ef05f1.ajax_pagination_infinite_stop="";block_td_uid_1_5a54ab5ef05f1.max_num_pages="1532";tdBlocksArray.push(block_td_uid_1_5a54ab5ef05f1);</script><div class="td_block_wrap td_block_related_posts td_uid_1_5a54ab5ef05f1_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_2_5a54ab5ef21b9" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_5a54ab5ef05f1" href="#">RELATED ARTICLES</a><a id="td_uid_3_5a54ab5ef2285" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_5a54ab5ef05f1" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_5a54ab5ef05f1 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/boys-hockey-mob-succumbs-narrowly-to-cony-hall-dale-monmouth/" rel="bookmark" title="Boys Hockey: MOB succumbs narrowly to Cony/Hall-Dale/Monmouth"><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/themes/Newspaper/images/no-thumb/xtd_218x150.png.pagespeed.ic.5DQdhTAKqT.png" alt=""/></a></div>                <a href="http://news.keepmecurrent.com/category/american-journal/buxton/" class="td-post-category">Buxton</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/boys-hockey-mob-succumbs-narrowly-to-cony-hall-dale-monmouth/" rel="bookmark" title="Boys Hockey: MOB succumbs narrowly to Cony/Hall-Dale/Monmouth">Boys Hockey: MOB succumbs narrowly to Cony/Hall-Dale/Monmouth</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/windham-westbrook-shuts-out-lawrence-skowhegan-mci/" rel="bookmark" title="Windham/Westbrook shuts out Lawrence/Skowhegan/MCI"><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/themes/Newspaper/images/no-thumb/xtd_218x150.png.pagespeed.ic.5DQdhTAKqT.png" alt=""/></a></div>                <a href="http://news.keepmecurrent.com/category/lakes-region-weekly/raymond/" class="td-post-category">Raymond</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/windham-westbrook-shuts-out-lawrence-skowhegan-mci/" rel="bookmark" title="Windham/Westbrook shuts out Lawrence/Skowhegan/MCI">Windham/Westbrook shuts out Lawrence/Skowhegan/MCI</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/defending-champs-take-down-yarmouth-on-the-road/" rel="bookmark" title="Defending champs take down Yarmouth on the road"><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/uploads/2018/01/x1DX_9569-218x150.jpg.pagespeed.ic.4Teh0PzQwJ.jpg" alt="" title="Defending champs take down Yarmouth on the road"/></a></div>                <a href="http://news.keepmecurrent.com/category/lakes-region-weekly/gray/" class="td-post-category">Gray</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/defending-champs-take-down-yarmouth-on-the-road/" rel="bookmark" title="Defending champs take down Yarmouth on the road">Defending champs take down Yarmouth on the road</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5a54ab5ef05f1" data-td_block_id="td_uid_1_5a54ab5ef05f1"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5a54ab5ef05f1" data-td_block_id="td_uid_1_5a54ab5ef05f1"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

<div id="disqus_thread">
    </div>

                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="  widget widget_search"><form role="search" method="get" class="td-search-form-widget" action="http://news.keepmecurrent.com/">
    <div>
        <input class="td-widget-search-input" type="text" value="" name="s" id="s"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search"/>
    </div>
</form></aside><div class="td-a-rec td-a-rec-id-sidebar "><script type='text/javascript'>googletag.cmd.push(function(){googletag.defineSlot('/23938892/CUR_FRONT_1_300X250',[300,250],'div-gpt-ad-1460033196331-0').addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().enableSyncRendering();googletag.enableServices();});</script>

​<!-- /23938892/CUR_FRONT_1_300X250 -->
<div id='div-gpt-ad-1460033196331-0' style='height:250px; width:300px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460033196331-0');});</script>
</div></div>		<aside class="  widget widget_recent_entries">		<div class="block-title"><span>Recent Posts</span></div>		<ul>
											<li>
					<a href="http://news.keepmecurrent.com/south-portland-girls-roll-at-windham-to-stay-undefeated/">South Portland girls roll at Windham to stay undefeated</a>
									</li>
											<li>
					<a href="http://news.keepmecurrent.com/boys-hockey-mob-succumbs-narrowly-to-cony-hall-dale-monmouth/">Boys Hockey: MOB succumbs narrowly to Cony/Hall-Dale/Monmouth</a>
									</li>
											<li>
					<a href="http://news.keepmecurrent.com/windham-police-notes-14/">Windham Police Notes</a>
									</li>
											<li>
					<a href="http://news.keepmecurrent.com/grow-gng-challenge-extended-to-march/">Grow GNG Challenge extended to March</a>
									</li>
											<li>
					<a href="http://news.keepmecurrent.com/inside-windham-254/">Inside Windham</a>
									</li>
					</ul>
		</aside><div class="td-a-rec td-a-rec-id-custom_ad_5 "><!-- /23938892/CUR_FRONT_1_300X600 -->
<div id='div-gpt-ad-1460035808376-0' style='height:600px; width:300px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460035808376-0');});</script>
</div></div>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_social_counter td_block_widget td_uid_4_5a54ab5f02697_rand td-pb-border-top"><h4 class="block-title"><span>STAY CONNECTED</span></h4><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">1,464</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/keepmecurrent">Like</a></span></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">537</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/currentreports">Follow</a></span></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span8">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://news.keepmecurrent.com/"><img src="http://news.keepmecurrent.com/wp-content/uploads/2016/05/xCurrent-Square-Logo-300x245.png.pagespeed.ic.th0TgW8Syu.png" alt=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Current Publishing
5 Fundy Road
Falmouth, Maine 04105
207-854-2577
Office hours: 8: a.m. - 5 p.m.<div class="footer-email-wrap">Contact us: <a href="mailto:info@keepmecurrent.com">info@keepmecurrent.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div><span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/keepmecurrent/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/currentreports" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></aside></div>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                                        </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Copyright 2016 -Sun Media Group                </div>
            </div>
        </div>
    </div>
    </div><!--close content div-->
</div><!--close td-outer-wrap-->

				<script type='text/javascript'>var seriesdropdown=document.getElementById("orgseries_dropdown");if(seriesdropdown){function onSeriesChange(){if(seriesdropdown.options[seriesdropdown.selectedIndex].value!=(0||-1)){location.href="http://news.keepmecurrent.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;}}seriesdropdown.onchange=onSeriesChange;}</script>
			

    <!--

        Theme: Newspaper by tagDiv 2015
        Version: 6.7.2 (rara)
        Deploy mode: deploy
        
        uid: 5a54ab5f03614
    -->

    <script src="http://news.keepmecurrent.com/wp-includes/js/jquery,_ui,_core.min.js,qver==1.11.4+jquery,_ui,_widget.min.js,qver==1.11.4+jquery,_ui,_mouse.min.js,qver==1.11.4+jquery,_ui,_resizable.min.js,qver==1.11.4+jquery,_ui,_draggable.min.js,qver==1.11.4+jquery,_ui,_button.min.js,qver==1.11.4+jquery,_ui,_position.min.js,qver==1.11.4+jquery,_ui,_dialog.min.js,qver==1.11.4+wpdialog.min.js,qver==4.9.1.pagespeed.jc.H31pt_gbrs.js"></script><script>eval(mod_pagespeed_Dk2M868_qS);</script>
<script>eval(mod_pagespeed_kTL1ZJM98_);</script>
<script>eval(mod_pagespeed_NR9rwuvef1);</script>
<script>eval(mod_pagespeed_pwwjxKtLjk);</script>
<script>eval(mod_pagespeed_OmiKTynRkc);</script>
<script>eval(mod_pagespeed_o8WZBwvDDi);</script>
<script>eval(mod_pagespeed_BaeQKFX3LB);</script>
<script>eval(mod_pagespeed_fL3bOZlWrD);</script>
<script>eval(mod_pagespeed_zMNL6GfqFX);</script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/themes/Newspaper/js/tagdiv_theme.js,qver=6.7.2.pagespeed.jm.bkWYIVusS7.js'></script>
<script src="http://news.keepmecurrent.com/wp-includes,_js,_comment-reply.min.js,qver==4.9.1+wp-content,_plugins,_better-weather,_includes,_libs,_better-framework,_assets,_js,_element-query.min.js,qver==2.2.0+wp-content,_plugins,_better-weather,_includes,_libs,_better-weather,_js,_skycons.js,qver==2.0.3.pagespeed.jc.qRu6whByZ7.js"></script><script>eval(mod_pagespeed_1oVIkx8_ET);</script>
<script>eval(mod_pagespeed_Y_F1FprhhT);</script>
<script>eval(mod_pagespeed_v2Vue5SJxh);</script>
<script type='text/javascript'>//<![CDATA[
var BW_Localized={"url":"http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php","action":"bw_ajax","apiKey":"","monthList":{"January":"January","February":"February","March":"March","April":"April","May":"May","June":"June","July":"July","August":"August","September":"September","October":"October","November":"November","December":"December"},"daysList":{"Sat":"Sat","Sun":"Sun","Mon":"Mon","Tue":"Tue","Wed":"Wed","Thu":"Thu","Fri":"Fri"},"stateList":{"clear":"Clear","rain":"Rain","light_rain":"Light Rain","drizzle":"Drizzle","light_rain_and_windy":"Light Rain And Windy","cloudy":"Cloudy","mostly_cloudy":"Mostly Cloudy","partly_cloudy":"Partly Cloudy","snow":"Snow","light_snow":"Light Snow","snow_and_breezy":"Snow and Breezy","snow_and_windy":"Snow and Windy","sleet":"Sleet","wind":"Wind","foggy":"Foggy","thunderstorm":"Thunderstorm","overcast":"Overcast","overcast_df":"Overcast DF","breezy_and_Partly_Cloudy":"Breezy and Partly Cloudy","breezy_and_mostly_cloudy":"Breezy and Mostly Cloudy","humid_and_mostly_cloudy":"Humid and Mostly Cloudy","windy_and_mostly_cloudy":"Windy And Most Cloudy","breezy_and_overcast":"Breezy and Overcast","flurries":"Flurries","flurries_df":"Flurries DF","dry_and_partly_cloudy":"Dry and Partly Cloudy","dry_and_partly_cloudy_df":"Dry and Partly Cloudy","dry_and_mostly_cloudy":"Dry and Mostly Cloudy","dry_and_mostly_cloudy_df":"Dry and Mostly Cloudy DF"}};
//]]></script>
<script src="http://news.keepmecurrent.com/wp-content/plugins/better-weather/includes/libs,_better-weather,_js,_betterweather.min.js,qver==2.0.3+assets,_js,_better-weather-widgets.js,qver==2.0.3.pagespeed.jc.zcNeAvkwe5.js"></script><script>eval(mod_pagespeed_2RzwnpjlcP);</script>
<script>eval(mod_pagespeed_YF9$l8tvPL);</script>
<script type='text/javascript' src='//maps.googleapis.com/maps/api/js?sensor=false&#038;ver=4.9.1'></script>
<script type='text/javascript'>//<![CDATA[
var ubermenu_data={"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","v":"3.2.1.1","configurations":["main"],"ajax_url":"http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php"};
//]]></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js,qver=3.2.1.1.pagespeed.jm.7spdxmAyo5.js'></script>
<script src="http://news.keepmecurrent.com/wp-content,_plugins,_dhvc-waypoint,_assets,_js,_script.min.js,qver==2.0.3+wp-content,_plugins,_dhvc-waypoint,_assets,_js,_script.v2.min.js,qver==2.0.3+wp-includes,_js,_wp-embed.min.js,qver==4.9.1.pagespeed.jc.CMnpkTxTGE.js"></script><script>eval(mod_pagespeed_fPvWAMXTYa);</script>
<script>eval(mod_pagespeed_jCofgPsHAJ);</script>
<script>eval(mod_pagespeed_XSSwwGYeqM);</script>
<script type='text/javascript'>//<![CDATA[
var embedVars={"disqusConfig":{"platform":"wordpress@4.9.1","language":""},"disqusIdentifier":"268953 http:\/\/news.keepmecurrent.com\/south-portland-girls-roll-at-windham-to-stay-undefeated\/","disqusShortname":"keepmecurrent","disqusTitle":"South Portland girls roll at Windham to stay undefeated","disqusUrl":"http:\/\/news.keepmecurrent.com\/south-portland-girls-roll-at-windham-to-stay-undefeated\/","options":{"manualSync":false},"postId":"268953"};
//]]></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.9.1'></script>
<script type='text/javascript'>//<![CDATA[
var countVars={"disqusShortname":"keepmecurrent"};
//]]></script>
<script type='text/javascript'>//<![CDATA[
var disqus_shortname=countVars.disqusShortname;(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}else{url=url[1];}nodes[i].parentNode.href=url+'#disqus_thread';}}var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());
//]]></script>

<!-- JS generated by theme -->

<script>jQuery().ready(function jQuery_ready(){tdAjaxCount.tdGetViewsCountsAjax("post","[268953]");});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='http://news.keepmecurrent.com/wp-content/themes/Newspaper-child/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='http://news.keepmecurrent.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script>


</body>
</html>