<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Westbrook Police Notes - Keep Me Current</title>
    <meta charset="UTF-8"/>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://news.keepmecurrent.com/xmlrpc.php"/>
    <meta property="og:image" content="http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg"/><meta name="author" content="Current Publishing">

<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://news.keepmecurrent.com/westbrook-police-notes-114/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Westbrook Police Notes - Keep Me Current"/>
<meta property="og:description" content="Arrests Anthony M. Cole, 37, of Brook Street, Sanford, on June 19 on charges of violating condition of release, sex trafficking and unlawful possession of scheduled drug, on Larrabee Road. Christian Tuyishime, 18, of Walker Street, on June 19 on a charge of criminal mischief, on Main Street. Devon M. MacVane, 27, of Scarborough, on"/>
<meta property="og:url" content="http://news.keepmecurrent.com/westbrook-police-notes-114/"/>
<meta property="og:site_name" content="Keep Me Current"/>
<meta property="article:tag" content="rss"/>
<meta property="article:section" content="Police Beat"/>
<meta property="article:published_time" content="2017-06-29T00:00:00-04:00"/>
<meta property="article:modified_time" content="2017-06-29T00:02:26-04:00"/>
<meta property="og:updated_time" content="2017-06-29T00:02:26-04:00"/>
<meta property="og:image" content="http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg"/>
<meta property="og:image:width" content="369"/>
<meta property="og:image:height" content="369"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Arrests Anthony M. Cole, 37, of Brook Street, Sanford, on June 19 on charges of violating condition of release, sex trafficking and unlawful possession of scheduled drug, on Larrabee Road. Christian Tuyishime, 18, of Walker Street, on June 19 on a charge of criminal mischief, on Main Street. Devon M. MacVane, 27, of Scarborough, on "/>
<meta name="twitter:title" content="Westbrook Police Notes - Keep Me Current"/>
<meta name="twitter:image" content="http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg"/>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maps.googleapis.com'/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; Feed" href="http://news.keepmecurrent.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; Comments Feed" href="http://news.keepmecurrent.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Keep Me Current &raquo; Westbrook Police Notes Comments Feed" href="http://news.keepmecurrent.com/westbrook-police-notes-114/feed/"/>
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/news.keepmecurrent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
<link rel='stylesheet' id='dashicons-css' href='http://news.keepmecurrent.com/wp-includes/css/dashicons.min.css,qver=4.8.pagespeed.ce.zzwOjyb-IC.css' type='text/css' media='all'/>
<link rel='stylesheet' id='wp-jquery-ui-dialog-css' href='http://news.keepmecurrent.com/wp-includes/css/A.jquery-ui-dialog.min.css,qver=4.8.pagespeed.cf.GGV3X-BN81.css' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-four-css' href='http://news.keepmecurrent.com/wp-content/plugins/font-awesome-4-menus/css/A.font-awesome.min.css,qver=4.7.0.pagespeed.cf.jBrWCt-D4j.css' type='text/css' media='all'/>
<link rel='stylesheet' id='orgseries-default-css-css' href='http://news.keepmecurrent.com/wp-content/plugins/organize-series/A.orgSeries.css,qver=4.8.pagespeed.cf.f8oSIa3t_Y.css' type='text/css' media='all'/>
<link rel='stylesheet' id='rs-plugin-settings-css' href='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/css/A.settings.css,qver=5.1.6.pagespeed.cf.5rzHaygmgO.css' type='text/css' media='all'/>
<style id='rs-plugin-settings-inline-css' type='text/css'>#rs-demo-id{}</style>
<link rel='stylesheet' id='google_font_open_sans-css' href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='google_font_roboto-css' href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='better-weather-css' href='http://news.keepmecurrent.com/wp-content/plugins/better-weather/includes/libs/better-weather/css/A.bw-style.min.css,qver=2.0.3.pagespeed.cf.iBYAO5dXFt.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/pro/assets/css/A.ubermenu.min.css,qver=3.2.1.1.pagespeed.cf.U0oqAwkzDS.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-black-white-2-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/css/skins/A.blackwhite2.css,qver=4.8.pagespeed.cf.3ORV6MNaSL.css' type='text/css' media='all'/>
<link rel='stylesheet' id='ubermenu-font-awesome-css' href='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/css/fontawesome/css/A.font-awesome.min.css,qver=4.3.pagespeed.cf.iIGKnvKx_M.css' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='http://news.keepmecurrent.com/wp-content/themes/Newspaper/A.style.css,qver=6.1c.pagespeed.cf.3DiuhbUCi6.css' type='text/css' media='all'/>
<style id='td-theme-child-css' media='all'>.wp-caption-text{text-align:right;padding:2px 1px}</style>
<link rel='stylesheet' id='js_composer_front-css' href='http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/A.js_composer.min.css,qver=4.11.2.pagespeed.cf.T30Vpn3vIW.css' type='text/css' media='all'/>
<link rel='stylesheet' id='dhvc-waypoint-css' href='http://news.keepmecurrent.com/wp-content/plugins/dhvc-waypoint/assets/css/A.style.css,qver=4.8.pagespeed.cf.QiSdOMchuc.css' type='text/css' media='all'/>
<link rel='stylesheet' id='dhvc-waypoint-v2-css' href='http://news.keepmecurrent.com/wp-content/plugins/dhvc-waypoint/assets/css/A.stylev2.min.css,qver=4.8.pagespeed.cf.cqDgGaF-uB.css' type='text/css' media='all'/>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-includes/js/jquery/jquery.js,qver=1.12.4.pagespeed.jm.pPCPAKkkss.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-includes/js/jquery/jquery-migrate.min.js,qver=1.4.1.pagespeed.jm.C2obERNcWh.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js,qver=5.1.6.pagespeed.jm.hKSbRSQ3n8.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js,qver=5.1.6.pagespeed.jm.ZqIGaMtVT-.js'></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/themes/Newspaper-child/dfp-gpt1.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='http://news.keepmecurrent.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://news.keepmecurrent.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://news.keepmecurrent.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 4.8"/>
<link rel='shortlink' href='http://news.keepmecurrent.com/?p=265122'/>
<link rel="alternate" type="application/json+oembed" href="http://news.keepmecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://news.keepmecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F&#038;format=xml"/>
<!--[if IE 9]> <script>var _gambitParallaxIE9 = true;</script> <![endif]--><style id="ubermenu-custom-generated-css"></style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://news.keepmecurrent.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.1.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface."/>

<!-- JS generated by theme -->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .post img";var td_ajax_url="http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.7.2";var td_get_template_directory_uri="http:\/\/news.keepmecurrent.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="snap";var tds_logo_on_sticky="";var tds_header_style="9";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="3";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#4db2ec";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var td_ad_background_click_link="";var td_ad_background_click_target="";</script>


<!-- Header style compiled by theme -->

<style>.block-title>span,.block-title>a,.block-title>label,.widgettitle,.widgettitle:after,.td-trending-now-title,.td-trending-now-wrapper:hover .td-trending-now-title,.wpb_tabs li.ui-tabs-active a,.wpb_tabs li:hover a,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab.vc_active>a,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab:hover>a,.td-related-title .td-cur-simple-item,.woocommerce .product .products h2,.td-subcat-filter .td-subcat-dropdown:hover .td-subcat-more,.td-weather-information:before,.td-weather-week:before{background-color:#222}.woocommerce div.product .woocommerce-tabs ul.tabs li.active{background-color:#222!important}.block-title,.td-related-title,.wpb_tabs .wpb_tabs_nav,.vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container,.woocommerce div.product .woocommerce-tabs ul.tabs:before{border-color:#222}.td-footer-wrapper{background-color:#999}.td-footer-wrapper::before{background-repeat:repeat}.td-footer-wrapper::before{opacity:.3}</style>

<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-328783-34','auto');ga('send','pageview');</script><noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript></head>

<body class="post-template-default single single-post postid-265122 single-format-standard westbrook-police-notes-114 wpb-js-composer js-comp-ver-4.11.2 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">


<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div id="td-mobile-nav">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-category-container"><ul id="menu-category" class=""><li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-39"><a href="http://news.keepmecurrent.com/category/news/">News</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-35"><a href="http://news.keepmecurrent.com/category/community/">Community</a>
<ul class="sub-menu">
	<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="http://news.keepmecurrent.com/category/calendar/">Calendar</a></li>
</ul>
</li>
<li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="http://news.keepmecurrent.com/category/lifestyle/">Lifestyle</a></li>
<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41"><a href="http://news.keepmecurrent.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"><a href="http://news.keepmecurrent.com/category/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-42" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42"><a href="http://news.keepmecurrent.com/category/police-beat/">Police Beat</a></li>
<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="http://news.keepmecurrent.com/category/sports/">Sports</a></li>
<li id="menu-item-249203" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-249203"><a href="http://news.keepmecurrent.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-249204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-249204"><a href="http://news.keepmecurrent.com/about-us/">About Us</a></li>
	<li id="menu-item-249466" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-249466"><a href="http://news.keepmecurrent.com/advertise/">Advertise</a>
	<ul class="sub-menu">
		<li id="menu-item-255734" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255734"><a href="http://local.keepmecurrent.com/">Local Business Directory</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-250775" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250775"><a href="http://classifieds.keepmecurrent.com">Classifieds</a></li>
</ul></div>    </div>
</div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 9
-->

<div class="td-header-wrap td-header-style-9">

    <div class="td-header-top-menu-full">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="td_data_time">Thursday, June 29, 2017</div><div class="menu-top-container"><ul id="menu-edition" class="top-header-menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-12"><a href="http://news.keepmecurrent.com/category/american-journal/">American Journal</a>
<ul class="sub-menu">
	<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13"><a href="http://news.keepmecurrent.com/category/american-journal/buxton/">Buxton</a></li>
	<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14"><a href="http://news.keepmecurrent.com/category/american-journal/gotham/">Gorham</a></li>
	<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-15"><a href="http://news.keepmecurrent.com/category/american-journal/westbrook/">Westbrook</a></li>
</ul>
</li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-16"><a href="http://news.keepmecurrent.com/category/current/">Current</a>
<ul class="sub-menu">
	<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-17"><a href="http://news.keepmecurrent.com/category/current/capeelizabeth/">Cape Elizabeth</a></li>
	<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-18"><a href="http://news.keepmecurrent.com/category/current/scarborough/">Scarborough</a></li>
	<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-19"><a href="http://news.keepmecurrent.com/category/current/southportland/">South Portland</a></li>
</ul>
</li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-20"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/">Lakes Region Weekly</a>
<ul class="sub-menu">
	<li id="menu-item-21" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-21"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/bridgton/">Bridgton</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-22"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/casco/">Casco</a></li>
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-23"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/gray/">Gray</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-24"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/naples/">Naples</a></li>
	<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-25"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/new-gloucdster/">New Gloucester</a></li>
	<li id="menu-item-26" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-26"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/raymond/">Raymond</a></li>
	<li id="menu-item-27" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-27"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/sebago/">Sebago</a></li>
	<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-28"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/standish/">Standish</a></li>
	<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-29"><a href="http://news.keepmecurrent.com/category/lakes-region-weekly/windham/">Windham</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-30"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/">Tri-Town Weekly</a>
<ul class="sub-menu">
	<li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-31"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/durham/">Durham</a></li>
	<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-32"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/freeport/">Freeport</a></li>
	<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-33"><a href="http://news.keepmecurrent.com/category/tri-town-weekly/pownal/">Pownal</a></li>
</ul>
</li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    <span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/keepmecurrent/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/currentreports" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></div>
    </div>

        </div>
    </div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-header-sp-logo">
                <span class="logo-text-container">
		<a class="td-logo-wrap" href="http://news.keepmecurrent.com/">
			<span class="td-logo-text">Keep Me Current</span>
			<span class="td-tagline-text">News from where you live</span>
		</a>
    </span>
	        </div>
    </div>

    <div class="td-header-menu-wrap-full">
        <div class="td-header-menu-wrap td-header-gradient">
            <div class="td-container td-header-row td-header-main-menu">
                <div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
            </div>
    <div class="menu-category-container"><ul id="menu-category-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-39"><a href="http://news.keepmecurrent.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-35"><a href="http://news.keepmecurrent.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-34"><a href="http://news.keepmecurrent.com/category/calendar/">Calendar</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-38"><a href="http://news.keepmecurrent.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-41"><a href="http://news.keepmecurrent.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-37"><a href="http://news.keepmecurrent.com/category/letters/">Letters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-42"><a href="http://news.keepmecurrent.com/category/police-beat/">Police Beat</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-43"><a href="http://news.keepmecurrent.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-249203"><a href="http://news.keepmecurrent.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-249204"><a href="http://news.keepmecurrent.com/about-us/">About Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-249466"><a href="http://news.keepmecurrent.com/advertise/">Advertise</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-255734"><a href="http://local.keepmecurrent.com/">Local Business Directory</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-250775"><a href="http://classifieds.keepmecurrent.com">Classifieds</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form role="search" method="get" class="td-search-form" action="http://news.keepmecurrent.com/">
				<div class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search"/>
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>            </div>
        </div>
    </div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header "><script type='text/javascript'>var gptAdSlots=[];googletag.cmd.push(function(){var bigLeaderMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([320,400],[320,50]).addSize([750,200],[728,90]).addSize([1024,768],[970,250]).build();var leaderMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([320,400],[320,50]).addSize([750,200],[728,90]).build();var sidebarMap=googletag.sizeMapping().addSize([0,0],[88,31]).addSize([750,250],[300,600]).build();gptAdSlots[0]=googletag.defineSlot('/23938892/CUR_ROP_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032504433-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[1]=googletag.defineSlot('/23938892/CUR_STORY_1_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032915837-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[2]=googletag.defineSlot('/23938892/CUR_STORY_2_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032989449-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[3]=googletag.defineSlot('/23938892/CUR_FRONT_1_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032611748-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[4]=googletag.defineSlot('/23938892/CUR_FRONT_2_728X90',[[728,90],[320,90]],'div-gpt-ad-1460032682508-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[5]=googletag.defineSlot('/23938892/CUR_FRONT_3_728X90',[[728,90],[320,50]],'div-gpt-ad-1460032790952-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[6]=googletag.defineSlot('/23938892/CUR_FRONT_2_300X250',[300,250],'div-gpt-ad-1460034409432-0').defineSizeMapping(leaderMap).addService(googletag.pubads());gptAdSlots[7]=googletag.defineSlot('/23938892/CUR_FRONT_1_300X600',[300,600],'div-gpt-ad-1460035808376-0').defineSizeMapping(sidebarMap).addService(googletag.pubads());googletag.pubads().setTargeting("test","responsive");googletag.enableServices();});</script>

<!-- /23938892/CUR_ROP_728X90 -->
<div id='div-gpt-ad-1460032504433-0' style='width: 728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032504433-0');});</script>
</div>
</div>
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://news.keepmecurrent.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Police Beat" class="entry-crumb" itemprop="url" href="http://news.keepmecurrent.com/category/police-beat/"><span itemprop="title">Police Beat</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content="Westbrook Police Notes"><meta itemprop="url" content="http://news.keepmecurrent.com/westbrook-police-notes-114/">Westbrook Police Notes</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-265122" class="post-265122 post type-post status-publish format-standard has-post-thumbnail hentry category-police-beat category-westbrook tag-rss" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            
            <header class="td-post-title">
                <h1 class="entry-title">Westbrook Police Notes</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://news.keepmecurrent.com/author/current-publishing/">Current Publishing</a> - </div>                    <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-06-29T00:00:00+00:00">June 29, 2017</time></div>                                        <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-265122">34</span></div>                </div>

            </header>

        </div>

        <div class="td-post-sharing td-post-sharing-top ">
				<div class="td-default-sharing">
		            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Share on Facebook</div></a>
		            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Westbrook+Police+Notes&url=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F&via=currentreports"><i class="td-icon-twitter"></i><div class="td-social-but-text">Tweet on Twitter</div></a>
		            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://news.keepmecurrent.com/westbrook-police-notes-114/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
		            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://news.keepmecurrent.com/westbrook-police-notes-114/&amp;media=http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg&description=Westbrook+Police+Notes" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
		            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Westbrook+Police+Notes - http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F"><i class="td-icon-whatsapp"></i></a>
	            </div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg" data-caption=""><img width="369" height="369" class="entry-thumb td-modal-image" src="http://news.keepmecurrent.com/wp-content/uploads/2017/06/xWestbrook-Police-Badge-2.jpg.pagespeed.ic.sXw2wl61JP.jpg" alt="" title=""/></a></div>
        <div class="td-a-rec td-a-rec-id-content_top ">​<!-- /23938892/CUR_STORY_1_728X90 -->
<div id='div-gpt-ad-1460032915837-0' style='maxwidth:728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032915837-0');});</script>
</div></div><h3>Arrests</h3>
<p>Anthony M. Cole, 37, of Brook Street, Sanford, on June 19 on charges of violating condition of release, sex trafficking and unlawful possession of scheduled drug, on Larrabee Road.</p>
<p>Christian Tuyishime, 18, of Walker Street, on June 19 on a charge of criminal mischief, on Main Street.</p>
<p>Devon M. MacVane, 27, of Scarborough, on June 19 on charges of domestic violence stalking, violating protective order from abuse, and criminal trespass, on Mechanic Street.</p>
<p>Yousef Q. Dawood, 21, of Westbrook, on June 20 on a charge of domestic violence assault, in Westbrook.</p>
<p>Christin E. Parmenter, 28, of Fenderson Road, Parsonfield, on June 21 on charges of operating while license suspended or revoked and violating condition of release, on Main Street.</p>
<p>Jacob A. Joiner, 20, of Bridgton Road, on June 22 on charges of unlawful possession of a scheduled drug, refusal to submit to arrest or detention, and burglary of a motor vehicle, on Everett Street.</p>
<p>Katelynn Henry, 24, of Oakland Avenue, on June 22 on charges of theft by unauthorized taking or transfer and violating condition of release, on Main Street.</p>
<p>Scott M. Brown, 53, of Westbrook, on June 22 on charges of theft by unauthorized taking or transfer and violating condition of release, on Hannaford Drive.</p>
<p>Victoria E. Beedle, 22, of Dunnell Road, Buxton, on June 23 on a charge of operating under the influence, on New Gorham Road.</p>
<p>Joshua Rasheme Jones, 33, of Westbrook, on June 23 on a charge of domestic violence assault, in Westbrook.</p>
<p>Stephen J. Hart, 28, of Fair Oaks Drive, Springvale, on June 23 on a charge of operating under the influence, on Westbrook Arterial Highway and Larrabee Road.</p>
<p>Gary L. Forest, 36, of Bonny Eagle Road, Standish, on June 24 on an outstanding warrant arrest, on Main Street.</p>
<p>Tyler Scott Benwell, 19, of Westbrook, on June 24 on charges of domestic violence assault, violating condition of release, and refusal to submit to arrest or detention, in Westbrook.</p>
<p>Joshua Rasheme Jones, 33, of Westbrook, on June 24 on a charge of violating condition of release, in Westbrook.</p>
<p>Matthew A. Theriault, 26, of Summit Terrace, South Portland, on a charge of criminal mischief, on North Street.</p>
<h3>Summonses</h3>
<p>Kayla A. Brooks, 25, of Prospect Street, Biddeford, on June 19 on charges of engaging in prostitution, violating condition of release, and possession of hypodermic apparatuses, on Larrabee Road.</p>
<p>Kayla M. Small, 22, of Teri Circle, on June 21 on charges of criminal mischief and violating condition of release, on Teri Circle.</p>
<p>Natasha C. Huff, 28, of Cole Street, on June 21 on a charge of endangering the welfare of a child, on Cole Street.</p>
<p>A 17-year-old juvenile (no gender or address listed), on June 22 on a charge of theft by unauthorized taking or transfer, on Hannaford Drive.</p>
<p>Eric K. Burnheimer, 33, of Central Street, on June 22 on charges of operating an unregistered motor vehicle for more than 150 days and operating while license suspended or revoked, on Main Street.</p>
<p>Margaret M. Boucher, 56, of Madison Street, on June 23 on a charge of theft by unauthorized taking, on Hannaford Drive.</p>
<p>A 15-year-old juvenile (no gender or address listed), on June 23 on a charge of theft by unauthorized taking or transfer, on Hannaford Drive.</p>
<p>Nicholas Whitelaw, 27, of Greenhill Road, Center Conway, New Hampshire, on June 23 on a charge of operating under the influence, on Main and Spring streets.</p>
<p>Matthew J. Dyer, 37, of Seavey Street, on charges of violating condition of release and trespass by motor vehicle, on Gowen Road.</p>
<p><img src="http://news.keepmecurrent.com/wp-content/uploads/2017/06/xWestbrook-Police-Badge-2.jpg.pagespeed.ic.sXw2wl61JP.jpg" alt="" title="" class="imagecache imagecache-medium"/></p>
<div class="td-a-rec td-a-rec-id-content_bottom ">​<!-- /23938892/CUR_STORY_2_728X90 -->
<div id='div-gpt-ad-1460032989449-0' style='maxwidth:728px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460032989449-0');});</script>
</div>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Westbrook+Police+Notes&url=http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F&via=currentreports"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://news.keepmecurrent.com/westbrook-police-notes-114/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://news.keepmecurrent.com/westbrook-police-notes-114/&amp;media=http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg&description=Westbrook+Police+Notes" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Westbrook+Police+Notes - http%3A%2F%2Fnews.keepmecurrent.com%2Fwestbrook-police-notes-114%2F"><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://news.keepmecurrent.com/westbrook-police-notes-114/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://news.keepmecurrent.com/westbrook-police-notes-114/" data-text="Westbrook Police Notes" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>                        <div class="author-box-wrap"><a href="http://news.keepmecurrent.com/author/current-publishing/"><img src="http://2.gravatar.com/avatar/e064b2421f78c4290b2977e5b26aa199?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default"/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://news.keepmecurrent.com/author/current-publishing/">Current Publishing</a></span></div><div class="td-author-url"><a href="http://www.keepmecurrent.com">http://www.keepmecurrent.com</a></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Current Publishing"></span><meta itemprop="datePublished" content="2017-06-29T00:00:00+00:00"><meta itemprop="dateModified" content="2017-06-29T00:02:26+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://news.keepmecurrent.com/westbrook-police-notes-114/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content=""></span><meta itemprop="name" content="Keep Me Current"></span><meta itemprop="headline " content="Westbrook Police Notes"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://news.keepmecurrent.com/wp-content/uploads/2017/06/Westbrook-Police-Badge-2.jpg"><meta itemprop="width" content="369"><meta itemprop="height" content="369"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_1_5954c93f4977f=new tdBlock();block_td_uid_1_5954c93f4977f.id="td_uid_1_5954c93f4977f";block_td_uid_1_5954c93f4977f.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_1_5954c93f4977f_rand","td_column_number":3,"live_filter_cur_post_id":265122,"live_filter_cur_post_author":"9"}';block_td_uid_1_5954c93f4977f.td_column_number="3";block_td_uid_1_5954c93f4977f.block_type="td_block_related_posts";block_td_uid_1_5954c93f4977f.post_count="3";block_td_uid_1_5954c93f4977f.found_posts="1011";block_td_uid_1_5954c93f4977f.header_color="";block_td_uid_1_5954c93f4977f.ajax_pagination_infinite_stop="";block_td_uid_1_5954c93f4977f.max_num_pages="337";tdBlocksArray.push(block_td_uid_1_5954c93f4977f);</script><div class="td_block_wrap td_block_related_posts td_uid_1_5954c93f4977f_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_2_5954c93f4a5dd" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_5954c93f4977f" href="#">RELATED ARTICLES</a><a id="td_uid_3_5954c93f4a687" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_5954c93f4977f" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_5954c93f4977f class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/gorham-police-notes-44/" rel="bookmark" title="Gorham Police Notes"><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/themes/Newspaper/images/no-thumb/xtd_218x150.png.pagespeed.ic.5DQdhTAKqT.png" alt=""/></a></div>                <a href="http://news.keepmecurrent.com/category/police-beat/" class="td-post-category">Police Beat</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/gorham-police-notes-44/" rel="bookmark" title="Gorham Police Notes">Gorham Police Notes</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/former-fire-chief-remembered-for-dedication-professionalism/" rel="bookmark" title="Former fire chief remembered for dedication, professionalism"><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/uploads/2017/06/xWestbrook_Fire_Chief_Rulman_award_062917-218x150.jpg.pagespeed.ic.TbD2dh5_dh.jpg" alt="" title="Former fire chief remembered for dedication, professionalism"/></a></div>                <a href="http://news.keepmecurrent.com/category/news/" class="td-post-category">News</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/former-fire-chief-remembered-for-dedication-professionalism/" rel="bookmark" title="Former fire chief remembered for dedication, professionalism">Former fire chief remembered for dedication, professionalism</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://news.keepmecurrent.com/building-a-beer-community-a-new-brewery-is-set-to-pour-in-westbrook/" rel="bookmark" title="Building a &#039;beer community&#039; : A new brewery is set to pour in Westbrook."><img width="218" height="150" class="entry-thumb" src="http://news.keepmecurrent.com/wp-content/uploads/2017/06/xYes_Brewing_co-owners_062917-218x150.jpg.pagespeed.ic.VPpg3HT-1g.jpg" alt="" title="Building a &#039;beer community&#039; : A new brewery is set to pour in Westbrook."/></a></div>                <a href="http://news.keepmecurrent.com/category/news/" class="td-post-category">News</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://news.keepmecurrent.com/building-a-beer-community-a-new-brewery-is-set-to-pour-in-westbrook/" rel="bookmark" title="Building a &#039;beer community&#039; : A new brewery is set to pour in Westbrook.">Building a &#039;beer community&#039; : A new brewery is set to pour in Westbrook.</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5954c93f4977f" data-td_block_id="td_uid_1_5954c93f4977f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5954c93f4977f" data-td_block_id="td_uid_1_5954c93f4977f"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->

<div id="disqus_thread">
    </div>

                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="  widget widget_search"><form role="search" method="get" class="td-search-form-widget" action="http://news.keepmecurrent.com/">
    <div>
        <input class="td-widget-search-input" type="text" value="" name="s" id="s"/><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search"/>
    </div>
</form></aside><div class="td-a-rec td-a-rec-id-sidebar "><script type='text/javascript'>googletag.cmd.push(function(){googletag.defineSlot('/23938892/CUR_FRONT_1_300X250',[300,250],'div-gpt-ad-1460033196331-0').addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.pubads().enableSyncRendering();googletag.enableServices();});</script>

​<!-- /23938892/CUR_FRONT_1_300X250 -->
<div id='div-gpt-ad-1460033196331-0' style='height:250px; width:300px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460033196331-0');});</script>
</div></div>		<aside class="  widget widget_recent_entries">		<div class="block-title"><span>Recent Posts</span></div>		<ul>
					<li>
				<a href="http://news.keepmecurrent.com/effort-underway-to-boost-tech-education-participation/">Effort underway to boost tech education participation</a>
						</li>
					<li>
				<a href="http://news.keepmecurrent.com/convince-us-council-says-of-plans-to-upgrade-high-school/">&#039;Convince us,&#039; council says of  plans to upgrade high school</a>
						</li>
					<li>
				<a href="http://news.keepmecurrent.com/gorham-notes-156/">Gorham Notes</a>
						</li>
					<li>
				<a href="http://news.keepmecurrent.com/paraschak-to-succeed-cole-in-gorham-2/">Paraschak to succeed Cole in Gorham</a>
						</li>
					<li>
				<a href="http://news.keepmecurrent.com/gorham-police-notes-44/">Gorham Police Notes</a>
						</li>
				</ul>
		</aside>		<div class="td-a-rec td-a-rec-id-custom_ad_5 "><!-- /23938892/CUR_FRONT_1_300X600 -->
<div id='div-gpt-ad-1460035808376-0' style='height:600px; width:300px;'>
<script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1460035808376-0');});</script>
</div></div>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Footer -->
<div class="td-footer-wrapper">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
			    		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_social_counter td_block_widget td_uid_4_5954c93f4dab1_rand td-pb-border-top"><h4 class="block-title"><span>STAY CONNECTED</span></h4><div class="td_social_type td-pb-margin-side td_social_facebook"><div class="td-sp td-sp-facebook"></div><span class="td_social_info">1,435</span><span class="td_social_info td_social_info_name">Fans</span><span class="td_social_button"><a href="https://www.facebook.com/keepmecurrent">Like</a></span></div><div class="td_social_type td-pb-margin-side td_social_twitter"><div class="td-sp td-sp-twitter"></div><span class="td_social_info">532</span><span class="td_social_info td_social_info_name">Followers</span><span class="td_social_button"><a href="https://twitter.com/currentreports">Follow</a></span></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span8">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="http://news.keepmecurrent.com/"><img src="http://news.keepmecurrent.com/wp-content/uploads/2016/05/xCurrent-Square-Logo-300x245.png.pagespeed.ic.th0TgW8Syu.png" alt=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Current Publishing
5 Fundy Road
Falmouth, Maine 04105
207-854-2577
Office hours: 8: a.m. - 5 p.m.<div class="footer-email-wrap">Contact us: <a href="mailto:info@keepmecurrent.com">info@keepmecurrent.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div><span class="td-social-icon-wrap"><a target="_blank" href="https://www.facebook.com/keepmecurrent/" title="Facebook"><i class="td-icon-font td-icon-facebook"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/currentreports" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></aside></div>            </div>
        </div>
    </div>
</div>

<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                                        </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; Copyright 2016 -Sun Media Group                </div>
            </div>
        </div>
    </div>
    </div><!--close content div-->
</div><!--close td-outer-wrap-->

				<script type='text/javascript'>var seriesdropdown=document.getElementById("orgseries_dropdown");if(seriesdropdown){function onSeriesChange(){if(seriesdropdown.options[seriesdropdown.selectedIndex].value!=(0||-1)){location.href="http://news.keepmecurrent.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;}}seriesdropdown.onchange=onSeriesChange;}</script>
			

    <!--

        Theme: Newspaper by tagDiv 2015
        Version: 6.7.2 (rara)
        Deploy mode: deploy
        
        uid: 5954c93f4e61d
    -->

    <script src="http://news.keepmecurrent.com/wp-includes/js/jquery,_ui,_core.min.js,qver==1.11.4+jquery,_ui,_widget.min.js,qver==1.11.4+jquery,_ui,_mouse.min.js,qver==1.11.4+jquery,_ui,_resizable.min.js,qver==1.11.4+jquery,_ui,_draggable.min.js,qver==1.11.4+jquery,_ui,_button.min.js,qver==1.11.4+jquery,_ui,_position.min.js,qver==1.11.4+jquery,_ui,_dialog.min.js,qver==1.11.4+wpdialog.min.js,qver==4.8.pagespeed.jc.dCc0t5TKaP.js"></script><script>eval(mod_pagespeed_Dk2M868_qS);</script>
<script>eval(mod_pagespeed_kTL1ZJM98_);</script>
<script>eval(mod_pagespeed_NR9rwuvef1);</script>
<script>eval(mod_pagespeed_pwwjxKtLjk);</script>
<script>eval(mod_pagespeed_OmiKTynRkc);</script>
<script>eval(mod_pagespeed_o8WZBwvDDi);</script>
<script>eval(mod_pagespeed_BaeQKFX3LB);</script>
<script>eval(mod_pagespeed_fL3bOZlWrD);</script>
<script>eval(mod_pagespeed_B7hLoRwOyT);</script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/themes/Newspaper/js/tagdiv_theme.js,qver=6.7.2.pagespeed.jm.bkWYIVusS7.js'></script>
<script src="http://news.keepmecurrent.com/wp-includes,_js,_comment-reply.min.js,qver==4.8+wp-content,_plugins,_better-weather,_includes,_libs,_better-framework,_assets,_js,_element-query.min.js,qver==2.2.0+wp-content,_plugins,_better-weather,_includes,_libs,_better-weather,_js,_skycons.js,qver==2.0.3.pagespeed.jc.k59hggQLnh.js"></script><script>eval(mod_pagespeed_nAFiyyKeTC);</script>
<script>eval(mod_pagespeed_Y_F1FprhhT);</script>
<script>eval(mod_pagespeed_v2Vue5SJxh);</script>
<script type='text/javascript'>//<![CDATA[
var BW_Localized={"url":"http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php","action":"bw_ajax","apiKey":"","monthList":{"January":"January","February":"February","March":"March","April":"April","May":"May","June":"June","July":"July","August":"August","September":"September","October":"October","November":"November","December":"December"},"daysList":{"Sat":"Sat","Sun":"Sun","Mon":"Mon","Tue":"Tue","Wed":"Wed","Thu":"Thu","Fri":"Fri"},"stateList":{"clear":"Clear","rain":"Rain","light_rain":"Light Rain","drizzle":"Drizzle","light_rain_and_windy":"Light Rain And Windy","cloudy":"Cloudy","mostly_cloudy":"Mostly Cloudy","partly_cloudy":"Partly Cloudy","snow":"Snow","light_snow":"Light Snow","snow_and_breezy":"Snow and Breezy","snow_and_windy":"Snow and Windy","sleet":"Sleet","wind":"Wind","foggy":"Foggy","thunderstorm":"Thunderstorm","overcast":"Overcast","overcast_df":"Overcast DF","breezy_and_Partly_Cloudy":"Breezy and Partly Cloudy","breezy_and_mostly_cloudy":"Breezy and Mostly Cloudy","humid_and_mostly_cloudy":"Humid and Mostly Cloudy","windy_and_mostly_cloudy":"Windy And Most Cloudy","breezy_and_overcast":"Breezy and Overcast","flurries":"Flurries","flurries_df":"Flurries DF","dry_and_partly_cloudy":"Dry and Partly Cloudy","dry_and_partly_cloudy_df":"Dry and Partly Cloudy","dry_and_mostly_cloudy":"Dry and Mostly Cloudy","dry_and_mostly_cloudy_df":"Dry and Mostly Cloudy DF"}};
//]]></script>
<script src="http://news.keepmecurrent.com/wp-content/plugins/better-weather/includes/libs,_better-weather,_js,_betterweather.min.js,qver==2.0.3+assets,_js,_better-weather-widgets.js,qver==2.0.3.pagespeed.jc.zcNeAvkwe5.js"></script><script>eval(mod_pagespeed_2RzwnpjlcP);</script>
<script>eval(mod_pagespeed_YF9$l8tvPL);</script>
<script type='text/javascript' src='//maps.googleapis.com/maps/api/js?sensor=false&#038;ver=4.8'></script>
<script type='text/javascript'>//<![CDATA[
var ubermenu_data={"remove_conflicts":"on","reposition_on_load":"off","intent_delay":"300","intent_interval":"100","intent_threshold":"7","scrollto_offset":"50","scrollto_duration":"1000","responsive_breakpoint":"959","accessible":"on","retractor_display_strategy":"responsive","touch_off_close":"on","v":"3.2.1.1","configurations":["main"],"ajax_url":"http:\/\/news.keepmecurrent.com\/wp-admin\/admin-ajax.php"};
//]]></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/ubermenu/assets/js/ubermenu.min.js,qver=3.2.1.1.pagespeed.jm.7spdxmAyo5.js'></script>
<script src="http://news.keepmecurrent.com/wp-content,_plugins,_dhvc-waypoint,_assets,_js,_script.min.js,qver==2.0.3+wp-content,_plugins,_dhvc-waypoint,_assets,_js,_script.v2.min.js,qver==2.0.3+wp-includes,_js,_wp-embed.min.js,qver==4.8.pagespeed.jc.311Y2SnsGo.js"></script><script>eval(mod_pagespeed_fPvWAMXTYa);</script>
<script>eval(mod_pagespeed_jCofgPsHAJ);</script>
<script>eval(mod_pagespeed_N68WCikLwX);</script>
<script type='text/javascript'>//<![CDATA[
var embedVars={"disqusConfig":{"platform":"wordpress@4.8","language":""},"disqusIdentifier":"265122 http:\/\/news.keepmecurrent.com\/westbrook-police-notes-114\/","disqusShortname":"keepmecurrent","disqusTitle":"Westbrook Police Notes","disqusUrl":"http:\/\/news.keepmecurrent.com\/westbrook-police-notes-114\/","options":{"manualSync":false},"postId":"265122"};
//]]></script>
<script type='text/javascript' src='http://news.keepmecurrent.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8'></script>
<script type='text/javascript'>//<![CDATA[
var countVars={"disqusShortname":"keepmecurrent"};
//]]></script>
<script type='text/javascript'>//<![CDATA[
var disqus_shortname=countVars.disqusShortname;(function(){var nodes=document.getElementsByTagName('span');for(var i=0,url;i<nodes.length;i++){if(nodes[i].className.indexOf('dsq-postid')!=-1&&nodes[i].parentNode.tagName=='A'){nodes[i].parentNode.setAttribute('data-disqus-identifier',nodes[i].getAttribute('data-dsqidentifier'));url=nodes[i].parentNode.href.split('#',1);if(url.length==1){url=url[0];}else{url=url[1];}nodes[i].parentNode.href=url+'#disqus_thread';}}var s=document.createElement('script');s.async=true;s.type='text/javascript';s.src='//'+disqus_shortname+'.disqus.com/count.js';(document.getElementsByTagName('HEAD')[0]||document.getElementsByTagName('BODY')[0]).appendChild(s);}());
//]]></script>

<!-- JS generated by theme -->

<script>jQuery().ready(function jQuery_ready(){tdAjaxCount.tdGetViewsCountsAjax("post","[265122]");});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='http://news.keepmecurrent.com/wp-content/themes/Newspaper-child/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='http://news.keepmecurrent.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script>


</body>
</html>